+ Reply to Thread
Results 1 to 8 of 8

Thread: Line too long

  1. #1

    Line too long

    I am trying to edit a .h file on Vedit 6.21 (08/05/11).

    After opening the file, as soon as I start moving cursor, I get an error message:
    "Line too long; {CONFIG, File handling, File type} now set to 64 (Binary)"
    and the file is switched to 64 column mode.

    The file does contain one line that is 296 characters long.
    But I thougt Vedit would be able to handle unlimited line length.

    Vedit 6.15 does not have problem editing this file in normal mode.

    --
    Pauli

  2. #2
    Senior Member
    Join Date
    Aug 2011
    Location
    British Columbia, Canada
    Posts
    383
    Hi Pauli,

    I am unable to replicate the problem with 6.21.1 7/17/2011

    One suggestion to try is rename your h.cft file to something else, just to elimate that anything in there is the problem.

    Scott


    Quote Originally Posted by pal View Post
    I am trying to edit a .h file on Vedit 6.21 (08/05/11).

    After opening the file, as soon as I start moving cursor, I get an error message:
    "Line too long; {CONFIG, File handling, File type} now set to 64 (Binary)"
    and the file is switched to 64 column mode.

    The file does contain one line that is 296 characters long.
    But I thougt Vedit would be able to handle unlimited line length.

    Vedit 6.15 does not have problem editing this file in normal mode.

    --
    Pauli

  3. #3
    Quote Originally Posted by Scott Lambert View Post
    Hi Pauli,
    I am unable to replicate the problem with 6.21.1 7/17/2011

    One suggestion to try is rename your h.cft file to something else, just to elimate that anything in there is the problem.
    I tried that, but it did not help.

    Then I noticed that the .h file was Unix file type (LF only).
    I converted it into DOS type (CR+LF), and now it can be edited.

    Looks like VEDIT 6.21.1 has some problem in handling Unix line-endings.

    --
    Pauli

  4. #4
    Administrator
    Join Date
    Aug 2011
    Location
    Ann Arbor, MI
    Posts
    103
    I cannot replicate it. I created a file with 2000 char lines, removed the CR (leaving just the LF) and I can open and edit it just fine.

    I suspect that your file-open configuration has a setting which is causing this problem. Rename the file to e.g. .hxx and see if the problem persists.
    If you are able to send me a set of files which replicate the problems, I would appreciate that. Others have reported this problem too, but I can never replicate it.

  5. #5

    Lightbulb

    I renamed the file, but it had no effect.

    Now I found out that the problem occurs if the first line of the file is an empty line.
    The line length or the total size of the file has no effect.
    Even if the file contains just one short line after the empty line, I get the "Line too long" error when trying to move from the first line to the 2nd line.
    The filename extension does not have effect either, it can be for example .txt.

    This happens both with Unix and Mac file types.
    However, with a Mac file, I may be able to press cursor down and up a few times before the error is displayed.

    --
    Pauli

  6. #6
    I can now very easily replicate it.
    Thanks for finding/reporting it.

  7. #7
    Senior Member
    Join Date
    Nov 2014
    Location
    Minneapolis, MN
    Posts
    303
    I have the same problem. Specifically, when I try to open the file PETER.DBF I get the error message,

    Line Too Long:
    Config, File handling
    File type now set to 64 (Binary).

    Then Vedit hangs and I have to use the win Ctrl-Alt-Del key combination to get out of Vedit.

    Fortunately, the file rename trick does work for me. In other words, if I rename
    PETER.DBF to PETER.TXT, then it works like a charm ! I have my phone directory on that file and I have been using it for about 15 years. Now all of a sudden, BOOM.

    Thanks,

    -peter

  8. #8
    Senior Member
    Join Date
    Nov 2014
    Location
    Minneapolis, MN
    Posts
    303
    Quote Originally Posted by rejto12 View Post
    I have the same problem. Specifically, when I try to open the file PETER.DBF I get the error message,

    Line Too Long:
    Config, File handling
    File type now set to 64 (Binary).

    Then Vedit hangs and I have to use the win Ctrl-Alt-Del key combination to get out of Vedit.

    Fortunately, the file rename trick does work for me. In other words, if I rename
    PETER.DBF to PETER.TXT, then it works like a charm ! I have my phone directory on that file and I have been using it for about 15 years. Now all of a sudden, BOOM.

    Thanks,

    -peter
    PROBLEM SOLVED !

    I made a mistake in my USER.MNU file that I use to open the PETER.DBF file.
    Specifically, my USER.MNU file did not end on an empty line. So, I pressed the "Enter" key and saved the file. This solved the problem.

    -peter
    Last edited by rejto12; July 17th, 2015 at 11:09 AM. Reason: Made it more complete.

+ Reply to Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts